Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#12055 closed bug (duplicate)

Memory Leak in IE8 when using custom events

Reported by: [email protected] Owned by: [email protected]
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

I'm seeing a memory leak in IE8/7 when binding custom events to a Jquery DOM object which is referenced in a JS object. IE9 seems fine. Using a standard event ('click') works fine as well.

Full code at http://jsfiddle.net/hah8n/1/

var testField = function ($in) {
  var $input = $in;
  var onCustom = function () { }

  this.Test = function () {
    $input.on('custom', onCustom);
  }
}

var $input = $("<span>" + Math.random() + "</span>").appendTo($row);
new testField($input).Test();

In the JSFiddle I also added clean-up code as a solution maybe - but it doesn't help. Also storing all instances of "testField" somewhere and then later deleting them (using "delete" command) did not help.

Any ideas, maybe some insights on custom events and special treatment in IE8?

Change History (4)

comment:1 Changed 10 years ago by dmethvin

Owner: set to [email protected]
Status: newpending

Can you try with 1.8b2 and see if the problem has been fixed?

comment:2 Changed 10 years ago by [email protected]

Status: pendingnew

That fixes it! Awesome!

comment:3 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Sweet!

comment:4 Changed 10 years ago by dmethvin

Duplicate of #7054.

Note: See TracTickets for help on using tickets.