Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12052 closed bug (duplicate)

.data() fails when retrieving large numbers

Reported by: iorlandoni@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Having a "data-something" attribute on an element containing a large number, trying to fetch it with .data() gives the original number +- 1. Same procedure using .attr('data-something') fetches the correct number.

Tested in : Chrome 22 (Canary) Chrome 20 Firefox 13

http://jsfiddle.net/OhCaN/F3cRJ/1/

Change History (2)

comment:1 Changed 5 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:2 Changed 5 years ago by dmethvin

Duplicate of #7579.

Note: See TracTickets for help on using tickets.