Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12030 closed bug (invalid)

.attr() bug drowser differences IE8

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: None
Component: attributes Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Browser: IE version 8.0.6001.18702 on WinXp Firefox 13.0.1 on same machine Jquery version 1.7.2

this code: typeof ($("> a", this).attr('href'))

applied on an anchor where the href is NOT set.

returns in firefox: "undefined" returns in ie: "string" (empty String)

Change History (2)

comment:1 Changed 7 years ago by addyosmani

Component: unfiledattributes
Owner: set to anonymous
Priority: undecidedlow
Status: newpending

Thanks for submitting a ticket to the jQuery bug tracker. Could you please provide us with a test case that reproduces the above issue on jsFiddle.net?. Please also be sure to test using the latest version of jQuery (jQuery-Git).

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.