Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12007 closed bug (duplicate)

missing offsetX and offsetY in firefox

Reported by: machnikv@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

In firefox are offsetX and offsetY in events undefined.

Bugfix: Paste into mouseHooks -> filter function (line 3384) befor 'return event;' this to lines:

event.offsetX = event.offsetX
event.clientX - jQuery(event.target).position().left;
event.offsetY = event.offsetY
event.clientY - jQuery(event.target).position().top;

Change History (3)

comment:1 Changed 7 years ago by anonymous

#edit

event.offsetX = event.offsetX || event.clientX - jQuery(event.target).position().left;
event.offsetY = event.offsetY || event.clientY - jQuery(event.target).position().top;

comment:2 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:3 Changed 7 years ago by dmethvin

Duplicate of #8523.

Note: See TracTickets for help on using tickets.