Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11973 closed bug (duplicate)

Animating background-position fails in IE8

Reported by: lgarvey Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

I'm attempting to animate a background image. As per the following jsfiddle:

http://jsfiddle.net/vEaMd/2/

This fails in IE8 ultimately because

 jQuery.css('backgroundPositionX')

on the div returns "right". In chrome it returns "100%" and in firefox it returns nothing. This breaks the animation since it cannot retrieve the starting position of the background to be animated.

The $.css inconsistency can be easily tested using the following jsfiddle:

http://jsfiddle.net/Zqj7t/

If someone can point me towards a jQuery test that fixes a similar cross-browser inconsistency I'd gladly write up a proper test-case and submit a patch via github

Change History (2)

comment:1 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:2 Changed 7 years ago by dmethvin

Duplicate of #11971.

Note: See TracTickets for help on using tickets.