Bug Tracker

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1195 closed bug (worksforme)

Attribute selector Form expando issue

Reported by: yehuda Owned by:
Priority: major Milestone: 1.1.3
Component: core Version: 1.1.2
Keywords: Cc:
Blocked by: Blocking:

Description

Forms respond (possibly) incorrectly to the attribute selector.

For instance, in the following form: <form> <input id="test" /> </form>

$("form[@test]") will return the form.

This is because the form element has a "test" expando caused by its elements, and the new [@xxx] selector includes JS attributes.

This unexpected behavior would happen for any browser-created expando.

Change History (2)

comment:1 Changed 13 years ago by brandon

Component: ajaxcore
Summary: Form expando issueAttribute selector Form expando issue

Ahhh geez... these form expando issues just won't go away.

comment:2 Changed 13 years ago by brandon

Resolution: worksforme
Status: newclosed

After looking at this in more detail, I've concluded that ... it is the proper behavior because the form has the property test that was created by the user when adding the input with id of test.

Note: See TracTickets for help on using tickets.