Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11932 closed bug (duplicate)

Reading left (and perhaps others) when % returns px in Opera & FF

Reported by: remysharp Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Example: http://jsbin.com/3/opufet/2

In Chrome (and Webkit based) value returns 50%.

In Firefox and Opera (not tested IE) value returns actual px value.

Should return consistent value - preferably the unit specified.

Change History (5)

comment:1 Changed 7 years ago by eoconnor@…

Please let me know if you think this is a bug in WebKit.

comment:2 Changed 7 years ago by damien

comment:3 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

This is a bug in webkit, and noted in source (https://github.com/jquery/jquery/blob/master/src/css.js#L566), and is a dupe of #9505.

Notice who is commenting on that bug report ;) https://bugs.webkit.org/show_bug.cgi?id=29084#c16

If anything, we're going to normalize to pixels, because that's the direction the browsers are going in, and is more useful for us internally.

comment:4 Changed 7 years ago by mikesherov

Duplicate of #9505.

comment:5 Changed 7 years ago by mikesherov

btw, I had also submitted a bug to W3C: https://www.w3.org/Bugs/Public/show_bug.cgi?id=16389

Note: See TracTickets for help on using tickets.