Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11927 closed feature (duplicate)

Implement EventSource

Reported by: brunoais Owned by: brunoais
Priority: undecided Milestone: None
Component: unfiled Version: git
Keywords: Cc:
Blocked by: Blocking:

Description

I'm interested in implementing EventSource in jQuery with a fallback towards AJAX for jQuery.

The idea is to encapsulate the Mobile browsers and IE incapability to properly support the EventSource object and to allow browsers that support EventSource to be able to use it at its fullest.

I have two main ideas I don't really know which is more "healthy" for jQuery, still I believe both are good ideas

One idea is to create a method that shares some options with the ajax method. It preforms the EventSource properly and, if EventSource is not available, use the ajax method with a setInterval() to keep things updated.

The other idea is to integrate such feature into the ajax method. This would require some more options into the anonymous object that is sent to this method but it would also make much sense anyway.

I have already read most of jQuery's code so I'm quite aware about how jQuery works internally.

One of the reasons I'm writing this is because I don't want to develop such feature if it is currently being developed by someone else. As there's no other ticket about EventSource (that I could find) I'm here to help the development of jQuery.

Change History (3)

comment:1 Changed 7 years ago by dmethvin

Owner: set to brunoais
Status: newpending

This seems like plugin material to me. Have you looked at @rwaldron's jquery.eventsource plugin?

comment:2 Changed 7 years ago by Rick Waldron

Resolution: duplicate
Status: pendingclosed

comment:3 Changed 7 years ago by Rick Waldron

Duplicate of #11926.

Note: See TracTickets for help on using tickets.