Bug Tracker

Opened 7 years ago

Closed 7 years ago

#11924 closed enhancement (invalid)

Add cross-browser fix for Opera 11.x regarding onhashchange

Reported by: Krinkle Owned by: Krinkle
Priority: low Milestone: None
Component: event Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Opera 11.1 and 11.5 (maybe more subversions) support onhashchange, but only via the window.onhashchange property, not via window.addEventListener.

I suggest we add a special handling for this event, just like we do for onbeforeunload.

Change History (4)

comment:2 Changed 7 years ago by mikesherov

Component: unfiledevent
Owner: set to Krinkle
Priority: undecidedlow
Status: newassigned

comment:3 Changed 7 years ago by Krinkle

You may close this as "invalid". The addEventListener is working in Opera 11.x fine. It wasn't working because my sample code omitted the third argument (usually "false") to addEventListener.

Opera doesn't give any feedback that it is required, just silently fails. Either way, as far as jQuery is concerned this is not a bug and the situation is fixed by simply passing false as the third argument (or using jQuery to begin with, in which case that wouldn't happen).

comment:4 Changed 7 years ago by Rick Waldron

Resolution: invalid
Status: assignedclosed

Cool, thanks for looking into this!

Note: See TracTickets for help on using tickets.