Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11886 closed bug (duplicate)

slideUp does nothing if the parent is hidden

Reported by: asj Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

slideUp does nothing if the parent is hidden. I understand it not animating, but it should at least hide the element it is run on and not rely on the parent being hidden.

A workaround is .slideUp(function() { $(this).hide; }) but this should not be necessary.

Change History (3)

comment:1 Changed 7 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

Thanks for the dup

comment:2 Changed 7 years ago by Rick Waldron

Duplicate of #11821.

comment:3 Changed 7 years ago by asj

Um, that bug is closed as worksforme which is wrong, since it does not work correctly for anyone. (Also #10201 which is the same bug - also closed.)

Just because the parent is hidden doesn't mean the command on the child should be ignored.

This is a bug, how else should I report it?

Note: See TracTickets for help on using tickets.