Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11869 closed bug (invalid)

Using $.each to iterate in a object with a number key is converting to string on callback

Reported by: jquery@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/7Tr3V/

I think I do expect a number in the first argument instead of a string, right?

Change History (3)

comment:1 Changed 7 years ago by dmethvin

Resolution: invalid
Status: newclosed

Nope. Keys are always strings. Blame ECMA if you must.

comment:2 Changed 7 years ago by Rick Waldron

Blitzed!

comment:3 Changed 7 years ago by dmethvin

#11870 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.