Bug Tracker

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#11851 closed bug (invalid)

IE9 crashes when using fadeout

Reported by: sbyard@… Owned by: sbyard@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have a DIV which is populated with a number of SPAN tags using JQUERY, which also attaches ONCLICK handlers that call the function below.

It works fine in CHROME and FIREFOX but crashes IE9. If I remove the line with Fadeout/FadeIn, IE9 works OK.

Further testing shows that ch.FadeOut is what causes the crash

function onCharacterSelected(event) {

_chSelected = event.data.charClicked;

call any attached functions for (var i = 0; i < _selectedCallbacks.length; i++)

_selectedCallbacks[i](event.data.charClicked);

reset selected in display t.children("span").each(function (index) { var ch = $(this);

if (ch.text() == _chSelected) { ch.removeClass("spanSelectList").addClass("spanSelectListSelected");

THE FADEOUT call causes IE9 to crash - MSHTML.dll (0x0000005 - memory access error) ch.fadeOut(200).fadeIn(200); } else { ch.removeClass("spanSelectListSelected").addClass("spanSelectList"); } });

}

Change History (17)

comment:1 Changed 7 years ago by sindresorhus

Owner: set to sbyard@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 7 years ago by anonymous

jsfiddle Example can be found at

http://jsfiddle.net/pixelda/yEEUk

IE9 still falls over when the sample code is executed in jsfiddle

comment:3 Changed 7 years ago by anonymous

I am also experiencing this with jquery 1.6.2, 1.6.4 and 1.7.2

comment:4 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:5 in reply to:  4 Changed 7 years ago by anonymous

Anyone have a solution?

comment:6 Changed 7 years ago by mikesherov

Resolution: invalid
Status: closedreopened

comment:7 Changed 7 years ago by mikesherov

Status: reopenedpending

Is this bug still happening using the edge version of jquery on jsfiddle?

comment:8 Changed 7 years ago by sbyard@…

Status: pendingnew

Yes

comment:9 Changed 7 years ago by mikesherov

Status: newpending

I'm unable to reproduce this issue. Do you have a simpler, more reliable example you can post on jsfiddle or jsbin to demonstrate the problem?

comment:10 Changed 7 years ago by pixelda2

Just keep clicking the buttons and occasionally click the "Z" and it will crash - i can make IE9 crash consistently on the jsfidlde site within 60 seconds.

I clicked "Y" then "Z" less than a dozen times on two occasions and IE9 crashed

comment:11 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:12 Changed 6 years ago by anonymous

It still determines IE9 to crash. It seems that fadeIn() is the culprit here. Can someone take a look at this problem?

comment:13 Changed 6 years ago by adrianpavel@…

Still reproducible.

comment:14 Changed 6 years ago by dmethvin

From the description, it sounds like this could be due to some browser add-in. A hard crash in MSHTML.DLL is not something we should be able to create in JavaScript. I cannot reproduce it in my local IE9 on Windows 7 with either the original 1.7.2 or the latest jquery-git.js which 1.9 will be based upon. Animations were rewritten in 1.8 so if the crash still occurs there it is even more likely to be due to some browser add-in.

comment:15 Changed 6 years ago by adrianpavel@…

It still can be reproduced with all add-ins disabled, so i don't think that this is the issue. Both with jQuery 1.7. or edge.

comment:16 Changed 6 years ago by adrianpavel@…

http://stackoverflow.com/questions/10080706/debugging-an-ie-crash

The explanation for the crash is here. And, yes: javascript DOES crash IE 9 rendering engine.

comment:17 Changed 6 years ago by dmethvin

Thanks for the followup. Not much jQuery can do about that.

Note: See TracTickets for help on using tickets.