Bug Tracker

Opened 7 years ago

Closed 7 years ago

#11828 closed bug (invalid)

Race condition in Chrome 19 in element.text() [more specifically element.empty()] when focus leaves body

Reported by: aar.now@… Owned by: aar.now@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/8Pr5H/4/

Step to reproduce:

  1. Use Chrome 19.0.1084.52 m
  2. Run given small jsFiddle snippet;
  3. Go to jsFiddle result pane, and fill something into input element;
  4. Click somewere NOT ON document body (e.g. address bar, developer tools console, etc);

Expected result: input element replaced by text typed in, and NO EXCEPTIONS;

Observerd result: input element replaced by text typed in, and exception thrown: "NOT_FOUND_ERR: DOM Exception 8"

IE and Firefox are not affected.

Reason: element emptying algorithm is invoked somewhere in middle of NEXT opertions with the element yielding inconsistent state of 'elem' object at line 5911. elem.firstChild is already set to new content (if any was produced from NEXT opertions), while physically DOM element is empty.

Anatoly

Change History (3)

comment:1 Changed 7 years ago by dmethvin

Owner: set to aar.now@…
Status: newpending

This sounds like a Chrome error that we cannot fix. Have you reported the problem to the Google Chrome team?

comment:2 Changed 7 years ago by artazor

Hmm... seems that it is related to jQuery interacting with bubbling of focusout. Because without bubbling it works just fine: http://jsfiddle.net/8Pr5H/5/

The same steps yield no error.

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.