Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11805 closed bug (duplicate)

data returns an integar instead of a string when the data is padded with 0's

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

reading .data('something') if data-something="000000001" the value returned is 1 when it should return 000000001

Change History (3)

comment:1 Changed 7 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

comment:2 Changed 7 years ago by Rick Waldron

Duplicate of #10174.

comment:3 Changed 7 years ago by Rick Waldron

If you need the value as a string, attr("data-something")

Note: See TracTickets for help on using tickets.