Bug Tracker

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1174 closed bug (duplicate)

Flicker before Interface SlideIn* functions

Reported by: bhagany Owned by:
Priority: major Milestone: 1.1.3
Component: ajax Version: 1.1.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have seen several posts on the forums that claim that something like this was fixed in jQuery 1.1.2, but this persists for me in Firefox 1.5 on Windows XP. In certain situations, the sliding element is made visible for a brief period before the slide actually starts, when display is unset or set to "block", and visibility is "none"

My preliminary fix is as follows:

comment out ifxslide.js, line 240 (jQuery.fx.slide method):

z.el.show();

and change ifx.js, line 110 (jQuery.fx.buildWrapper method) from:

t.hide();

to

es.display = "none";

I'm not sure what the reason was for having the z.el.show() command, but it seems to work well without it. Also, under the conditions I described above, the t.hide() call doesn't actually do anything when z.el.show() is commented, because hide() does a filter(":visible") before doing its thing, and the element's visibility is set to none.

Any insight on whether this fix breaks anything else is appreciated. Also, I will put up a test case and post it here soon.

Change History (2)

comment:1 Changed 14 years ago by bhagany

Sorry... please ignore this ticket, and use #1176 instead

comment:2 Changed 14 years ago by brandon

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.