Bug Tracker

Opened 6 years ago

Closed 6 years ago

#11730 closed bug (invalid)

text() wrapper method error

Reported by: Luis Owned by: Luis
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Exampĺe: i have a div with id "barraNavegacion" with html content. The following error occurs both in normal run and in firebug/chrome consoles.

writing $("#barraNavegacion").text() returns an array of dom elements. BUT i tried calling: $("#barraNavegacion").text().text() and it did not crash: the returned element is not a normal array of dom elements: it's the actual wrapper, as in calling $("#barraNavegacion").text("text to set"), when it should return the actual text content.

Change History (4)

comment:1 Changed 6 years ago by Rick Waldron

Owner: set to Luis
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the "jQuery (edge)" version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to begin.

I've attempted to reproduce it here, but cannot http://jsfiddle.net/rwaldron/FUZbe/

comment:2 Changed 6 years ago by Luis

Status: pendingnew

Note: in version 1.7.1 this bug does not appear. this was not tested in IE, but in FF and Chrome.

comment:3 Changed 6 years ago by dmethvin

Status: newpending

We do need a test case, not including plugins. Most likely one of your plugins is causing this. If you determine which one, please let us know.

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.