Bug Tracker

Opened 7 years ago

Closed 7 years ago

#11700 closed enhancement (duplicate)

Reduce Method

Reported by: ajrkerr@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

I think that it would make sense for there to be a reduce/fold method in jQuery. There is already an each and a map, and I think that reduce makes sense for pulling data from the DOM. It would allow for something like this:

total = $(".prices").reduce(function (a, b) { return a + b.text() }, 0)

I understand that this can be done by using multiple libraries (ie. Underscore and jQuery), however given all of the other methods which are available through jQuery (ie. map, each, filter, etc.) this does not seem to be outside the scope of this library.

Change History (3)

comment:1 Changed 7 years ago by Rick Waldron

Resolution: plugin
Status: newclosed

Thanks! This can be implemented as a plugin.

comment:2 Changed 7 years ago by Rick Waldron

Resolution: plugin
Status: closedreopened

comment:3 Changed 7 years ago by Rick Waldron

Resolution: duplicate
Status: reopenedclosed

Duplicate of #1886.

Note: See TracTickets for help on using tickets.