Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11647 closed bug (invalid)

.attr and .prop fails to set name in ie7

Reported by: pasi.luostarinen@… Owned by: pasi.luostarinen@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

In internet explorer 7 jquery fails to set name attribute on a element. The ie9 and ie8 in ie7 mode will work but in real ie7 it fails.

http://pastebin.com/HMtLB01i this sample code you can replicate the bug. In chrome, ff and opera you can click radio buttons correctly but in a real ie7 it fails.

My test ie7 is windows xp (no sp) in virtualbox and original ie7 package from microsoft.

Change History (4)

comment:1 Changed 7 years ago by Rick Waldron

Owner: set to pasi.luostarinen@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the "jQuery (edge)" version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to begin.

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 7 years ago by ksebion@…

I ran into this bug also; http://jsfiddle.net/p6Rf3/

Google Chrome 18.0.1025.168 m: FAIL Google Chrome 19.0.1084.46 m: FAIL Internet Explorer 9.0.8112.16241: FAIL Mozilla Firefox 11.0: FAIL Mozilla Firefox 12.0: FAIL Opera 11.62: FAIL Safari 5.1.7: FAIL

comment:4 Changed 7 years ago by dmethvin

@ksebion, you've misunderstood the roles of properties and attributes. The id property/attribute is reflected, but the name is not. If you need more help ask on a forum, since this is not a bug.

Note: See TracTickets for help on using tickets.