Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11646 closed bug (duplicate)

jQuery selectors not working for <param> element inside <object> element in IE < 9

Reported by: TimJRobinson Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Discovered today that in any version of IE prior to 9 jQuery isn't correctly getting child <param> elements for an <object> element.

As can be seen in this JSFiddle:

http://jsfiddle.net/uGpUy/2/

Also even using find() isn't working. If you have multiple <object> elements with multiple <param>'s in each and you loop through the objects getting the parameters for each it instead finds every parameter on the page. You can see this in:

http://jsfiddle.net/uGpUy/6/

In IE8 it is returning 0 for the lengths of all the first 4 console.log's and 5 for the last two.

This fiddle appears to be working correctly in all modern browsers, IE8 and below are all broken.

Change History (2)

comment:1 Changed 7 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

comment:2 Changed 7 years ago by Rick Waldron

Duplicate of #9597.

Note: See TracTickets for help on using tickets.