Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11612 closed bug (duplicate)

slideDown and slideUp animation bump at start when first element is p

Reported by: keithphw@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hi, I've noticed a strange bug in slideUp and slideDown where the animation bumps at the very start. It only happens when the first and last elements are p (paragraph) elements. If they are not p elements, just plain text, there is no bump. Here is a simple test case: http://www.keithwoodward.com/miscellaneous/jquerybugexample/jquery_bumy_animation.html The animation when the left button is clicked jumps at the start whereas the one on the right does not. Great work with jquery btw, it makes javascript a lot easier. Best wishes, Keith

Change History (4)

comment:1 Changed 7 years ago by anonymous

Related to this bug (http://bugs.jquery.com/ticket/8370) I read the final comment in why that bug is closed without being fixed. It says that the component height can not be known. But my example shows that there is more that can be done on the jQuery side to fix the issue since the misbehaviour only occurs due to the first and last p elements and each p element has the same height with no overflow. Clearly the paragraph heights are being mis-read in jQuery somewhere. Thanks for your time. Keith

comment:2 Changed 7 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

comment:3 Changed 7 years ago by Rick Waldron

Duplicate of #8370.

comment:4 Changed 7 years ago by anonymous

Thanks for seeing to my bug ticket rwaldron. But I don't understand how this is a duplicate. First, the animation bump happens at the start of a slideUp in my case, not the end as in 8370. This suggests that the 'unknown height' problem is not the cause of this bug. Second, my bug only occurs when p elements are at the beginning and end. Having p elements in the middle has no effect, indicating that the cause of the bug is related to the type of first and/or last elements, not the elements in the middle. This would suggest that the bug is not related to setting the component width as is suggested in bug 8370. What do you think? Best regards, Keith

Note: See TracTickets for help on using tickets.