Bug Tracker

Opened 8 years ago

Closed 7 years ago

#11603 closed bug (invalid)

.animate() bug in IE 6,7,8

Reported by: gpk_urmc Owned by: gpk_urmc
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

There is a bug with calling .animate() under certain circumstances in IE 6,7, and 8.

You can see an example on this page:
http://codecanyon.net/item/paradigm-slider-jquery-plugin/full_screen_preview/829647

Mouse over, then out of the "Dark Style" slider.

An error occurs in jquery.js at line 8988 character 5. In jQuery source, this is Line 8826:
fx.elem.style[ fx.prop ] = fx.now + fx.unit;

The call stack goes back to this call:
e.cssAnimate({left:0-g.slideFactorX+"px",top:0-g.slideFactorY+"px"},{duration:200,queue:false});

where obj.slideFactorX and obj.slideFactorY are both zero.

Change History (5)

comment:1 Changed 8 years ago by Rick Waldron

Owner: set to gpk_urmc
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the "jQuery (edge)" version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to begin.

comment:2 Changed 7 years ago by anonymous

This is not a bug.

I had this issue, when I calculated .animate() properties based on some css values. In IE6-8, those values were simply set to "auto", while in other browsers they were "0px".

I solved this by explicitly setting the needed style property in css file.

comment:3 Changed 7 years ago by brian@…

I would argue that it should still be considered a bug. If frameworks like jQuery are meant to simplify development, that means providing standard responses across platforms and browsers (something jQuery has done a remarkably good job with, considering). If we go back to the old days of accepting browser-specific hacks, then what is the point of all this?

comment:4 Changed 7 years ago by dmethvin

@brian, patches are always welcome. It will give you a chance to explore the complexity of determining dimensions in oldIE.

comment:5 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.