Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11576 closed bug (duplicate)

innerHTML issues

Reported by: mendrik76@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

Dear mother of god! I've spent 3h debugging an IE8- bug today. Here is what happened. Whenever you use innerHTML to create new elements, ie will modify the original markup. In form tags particularly it moves the action attribute to the end of the tag and any attribute value without spaces will be stripped off its quotes. Now any url with a trailing slash will force the form tag to close itself. $("<form action="test/bla/"><input></form>) will become <form action=test/bla/><input/></form/>. Not sure JQuery can do anything about it. I fixed my project by adding a query string to the urls.

Change History (2)

comment:1 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:2 Changed 7 years ago by dmethvin

Duplicate of #6236.

Note: See TracTickets for help on using tickets.