Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11572 closed bug (duplicate)

attr's argument's length may be changed

Reported by: lining041038@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

when some other js code override attr function, it may be always send arguments more the one, then code's behind: return jQuery.access( this, jQuery.attr, name, value, arguments.length > 1 ); will go not correctly, i view this problem when i use tinymce fulltext components and when i use like $("a").attr("class"), it will be deal as chainable. the other auguments will be undefined. it has no problem in jquery version 1.6.2. i don't know if it should let other changing their code or change the jquery core.

Change History (2)

comment:1 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by Rick Waldron

Duplicate of #11527.

Note: See TracTickets for help on using tickets.