Bug Tracker

Opened 8 years ago

Closed 8 years ago

#11561 closed bug (invalid)

v. 1.7.2 - iframe inside jquery dialog reloads content multiple times

Reported by: zwonimir@… Owned by:
Priority: low Milestone: None
Component: misc Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hi all! I discovered this bug and somebody else on the net has the same problem but he didn't solve it:

i have an iframe inside a jquery dialog, and the dialog has some flashy animations when showed and hided:

$('#dialog_div').dialog({ autoOpen: false
, modal: true, show: 'clip', hide: 'clip', width: 600, height: 350});

$('#dialog_div').dialog('open');
$('#dialog_iframe').attr('src', 'content.aspx');

the problem is that the page "content.aspx" loads two times when I open the dialog and two times when I close the dialog with the command "$('#dialog_div').dialog('close');".

I found that the problem is the animation applied on the dialog, because if I remark the options "show: 'clip', hide: 'clip'," of the dialog the iframe fires only one time when I show the dialog.

Thanks! Zwonimir

Change History (1)

comment:1 Changed 8 years ago by sindresorhus

Component: unfiledmisc
Priority: undecidedlow
Resolution: invalid
Status: newclosed

Thanks for submitting a ticket to the jQuery bug tracker. Unfortunately we only handle issues to do with jQuery core. For assistance with jQuery UI please either submit your issue to their bug tracker http://bugs.jqueryui.com or ask for further assistance in #jquery on freenode.

Note: See TracTickets for help on using tickets.