Bug Tracker

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#11559 closed bug (invalid)

"Bugs with API site"

Reported by: cwillu@… Owned by: jdsharp
Priority: low Milestone: None
Component: web Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

Table of contents pages snap to the top of the window when alt-tabbing or mousing back to the window, causing a reader to lose his place when reviewing the documentation.

This appears to be caused by the search control having focus, causing focus events to be triggered when the window regains focus, despite the user never intending to perform a search.

Clicking outside the search box to remove the focus restores sane behaviour.


Additionally, the bug tracker link at the bottom of the api page is broken, apparently pointing to http://dev.jquery.com/ instead of http://bugs.jquery.com/


Finally, overriding the arrow keys is a somewhat rude thing to do, especially when the end result performs much worse than the browser's default navigation.

Change History (4)

comment:1 Changed 8 years ago by ngharo@…

Line 122 of navi.js catches focus to search input and calls $.navi.reset(). Line 32,33 of reset() sets scrollTop to 0.

comment:2 Changed 7 years ago by mikesherov

Component: unfiledweb
Owner: set to jdsharp
Priority: undecidedlow

comment:3 Changed 7 years ago by dmethvin

Keywords: needsdocs added
Resolution: invalid
Status: newclosed

Somewhat unconventional use of needsdocs but since this is the core bug tracker it isn't something that goes into jquery.js.

comment:4 Changed 7 years ago by mikesherov

Keywords: needsdocs removed

no longer relevant.

Note: See TracTickets for help on using tickets.