Bug Tracker

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11557 closed bug (duplicate)

Deep $.extend does not properly copy properties of custom objects

Reported by: wachunga@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

See repro: http://jsfiddle.net/WjYWh/

One could argue that $.extend should not be expected to work with custom objects like this, but there are test cases suggesting otherwise: https://github.com/jquery/jquery/blob/master/test/unit/core.js#L898

Being able to extend such objects (their properties, anyway) would be very nice. And in any case this kind of thing should be made explicit in the docs: http://api.jquery.com/jQuery.extend/ (Currently there's a disclaimer about primitive types, but that's it.)

This issue was previously reported, but the reporter didn't follow up with a repro so it was closed: http://bugs.jquery.com/ticket/10014

I tested 1.7.1 and 1.7.2, though that fiddle is currently for edge.

Change History (2)

comment:1 Changed 4 years ago by rwaldron

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 4 years ago by rwaldron

Duplicate of #10014.

Note: See TracTickets for help on using tickets.