Bug Tracker

Opened 8 years ago

Closed 8 years ago

#11550 closed bug (cantfix)

Jquery effects don't work if breakpoint debugging in Firebug

Reported by: armyofda12mnkeys Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

Here is an example, i got 2 friends to reproduce... http://jsfiddle.net/armyofda12mnkeys/7uztL/2/

Without any breakpoints the 1st red rectangle slides down perfectly. However if you set breakpoints on lines 30 and 36 (the 'yayyyyy1' and 'yayyyyy2' console.log statements) in jsfiddle's code (might need to search for 'yayyyyy1' in the Firebug Script's tab to the my code first to set the breakpoint), then it only shows 3px of the rectangle and never finished the effect. Im not sure if this is a known consequence of using Firebug with jquery effects, and where the problem is fixable.

I had this in a more complex ajax app that loads new questions/content via a jquery effect, and the new question never loads since the effect goes bad... and i have to manually set the div's css style that the effect seemed to add [but didn't change] (from: "overflow: hidden; height: 1px; display: block; margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px;" to "display:block;"). Btw, sometimes a jquery 'tick' function i think repeately tries to set it back, so I have to go and set "display:block" again.

Change History (1)

comment:1 Changed 8 years ago by dmethvin

Resolution: cantfix
Status: newclosed

If it runs fine without the debugger, sounds like this should be reported to Firebug.

Note: See TracTickets for help on using tickets.