Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11549 closed bug (duplicate)

Delegating click doesn't trigger middle click on Chrome

Reported by: poupougnac Owned by:
Priority: low Milestone: None
Component: event Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

I need to detect the middle click for a click event. If I do

$("#container a").on("click",...)

the middle click will fire the event... but not if I do :

$("#container").on("click","a",...)

The behavior appears only on Chrome and several users of my website reported it. Thank you for your support.

Change History (2)

comment:1 Changed 8 years ago by sindresorhus

Component: unfiledevent
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by sindresorhus

Duplicate of #11485.

Note: See TracTickets for help on using tickets.