Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11529 closed bug (duplicate)

.attr("name") returns this instead of the attribute

Reported by: rrajani@… Owned by:
Priority: low Milestone: None
Component: attributes Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

.attr("name") doesn't return the attribute anymore but returns the jquery object on which the function is being called. This must be related to #10396 which introduced chaining when setting an attribute to undefined. However this has broken the getter version of this function.

Change History (3)

comment:1 Changed 8 years ago by sindresorhus

Component: unfiledattributes
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by sindresorhus

Duplicate of #11527.

comment:3 Changed 8 years ago by Rick Waldron

Can you list here all the other scripts or jQuery Plugins you're using in your code? Thanks!

Note: See TracTickets for help on using tickets.