Bug Tracker

Opened 8 years ago

Closed 7 years ago

#11525 closed bug (invalid)

Animated toggle doesn't restore width of parent in Chrome

Reported by: Antti29 Owned by:
Priority: low Milestone: None
Component: css Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have a fixed-width div inside a td element. I'm trying to toggle the width of the div using .toggle(1000) and .animate({width: 'toggle'}, 1000), neither of which work properly in Chrome, but do in Mozilla and IE. The problem is that when the width is restored, the width of the parenting td element doesn't change back to normal. In addition, if you look closely at the end of the "shrink" animation, you'll see that the width of the div briefly flashes at the width of its contents. Could be unrelated, but still something not seen in the other browsers. The toggle without the delay parameter works as intended.

The accompanying jsFiddle is here: http://jsfiddle.net/yue96/1/

Change History (1)

comment:1 Changed 7 years ago by Rick Waldron

Component: unfiledcss
Priority: undecidedlow
Resolution: invalid
Status: newclosed

This is not a jQuery bug. All you need to do is a width to the TD.

Note: See TracTickets for help on using tickets.