Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11519 closed bug (duplicate)

String replace BUG

Reported by: [email protected] Owned by: [email protected]
Priority: undecided Milestone: None
Component: attributes Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hi.

The following instruction:

var idToDelete = jq(this).attr('id').replace('recordis-',);

that work with jquery 1.7.1, now with version 1.7.2 does not work anymore.

Error is 'replace is not a function'.

Thanks.

Change History (3)

comment:1 Changed 10 years ago by Rick Waldron

Component: unfiledattributes
Owner: set to [email protected]
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the "jQuery (edge)" version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to begin.

comment:2 Changed 10 years ago by Rick Waldron

Resolution: duplicate
Status: pendingclosed

Caused by attr() returning incorrect value

Can you list here all the other scripts or jQuery Plugins you're using in your code? Thanks!

comment:3 Changed 10 years ago by Rick Waldron

Duplicate of #11527.

Note: See TracTickets for help on using tickets.