Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11516 closed bug (duplicate)

.attr('value') returns object instead of value

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

$('input#id').attr('value') returns object instead of value

Change History (10)

comment:1 Changed 10 years ago by Rick Waldron

#11518 is a duplicate of this ticket.

comment:2 Changed 10 years ago by Rick Waldron

Owner: set to anonymous
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the "jQuery (edge)" version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to begin.

comment:3 Changed 10 years ago by anonymous

Status: pendingnew

please make bugfix.

comment:4 Changed 10 years ago by anonymous

this bug has something with content load via ajax.

comment:5 Changed 10 years ago by Rick Waldron

Resolution: invalid
Status: newclosed

This is not a jQuery bug - I'm closing for now. If you can reproduce this issue in a jsfiddle, please post back and we will be happy to look at it.

comment:6 Changed 10 years ago by sindresorhus

Resolution: invalid
Status: closedreopened

comment:8 Changed 10 years ago by sindresorhus

Duplicate of #11527.

comment:9 Changed 10 years ago by sindresorhus

Resolution: duplicate
Status: reopenedclosed

comment:10 Changed 10 years ago by sindresorhus

Duplicate of #11527.

comment:11 Changed 10 years ago by Rick Waldron

Can you list here all the other scripts or jQuery Plugins you're using in your code? Thanks!

Note: See TracTickets for help on using tickets.