Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11512 closed bug (duplicate)

$(this).attr('id')

Reported by: [email protected] Owned by: [email protected]
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

In 1.7.2, alert($(this).attr('id')); will output [Object], but same code works fine in 1.7.1 (output the string ID)

Change History (5)

comment:1 Changed 10 years ago by sindresorhus

Owner: set to [email protected]
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 10 years ago by anonymous

I can not reproduce this bug with jsfiddle. Bug alert($('#'+areaId).attr('editor')); print [object Object] too.

comment:3 Changed 10 years ago by Rick Waldron

Can you list here all the other scripts or jQuery Plugins you're using in your code? Thanks!

comment:4 Changed 10 years ago by Rick Waldron

Resolution: duplicate
Status: pendingclosed

comment:5 Changed 10 years ago by Rick Waldron

Duplicate of #11527.

Note: See TracTickets for help on using tickets.