Bug Tracker

Opened 13 years ago

Closed 12 years ago

#1151 closed bug (wontfix)

Sortable width on drag

Reported by: ds.highwind Owned by: stefan
Priority: minor Milestone: 1.2
Component: interface Version: 1.1.2
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by scott.gonzal)

There is a problem with sortables made of unordered lists (at lest in IE7). Suppose you have <ul class="sortable" id="sortable">

<li class="sortableitem">Item 1</li> <li class="sortableitem">Item 2</li>

</ul> <style type="text/css"> .sortable{

margin:0; padding-left:0px; list-style: none;

} .sortableitem {

cursor:default; border:1px solid silver; background:#f0f0ee; margin:1px; padding-left:2px;

} </style> <script type="text/javascript"> $(document).ready(

function () {

$('ul').Sortable(

{

accept : 'sortableitem', axis: 'vertically',

}

)

}

); </script>

The problem is as follows: when you start dragging an element it changes it's width/left offset. It is quite strange because in firefox everything is ok. It is certainly not a browser bug because everything is fine in script.aculo.us sortable demo.

Change History (1)

comment:1 Changed 12 years ago by scott.gonzal

Description: modified (diff)
Resolution: wontfix
Status: newclosed

Interface is no longer supported; consider switching to jQuery UI.

Note: See TracTickets for help on using tickets.