Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11445 closed bug (duplicate)

Parsing error on data

Reported by: shholmes@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have an html like this:

<input type="radio"
 class="class" 
 name="attr" 
 value="value" 
 data-identifier="13309600171026321254"/>

When I try to retrieve the identifier data attribute it recognizes it as a number and parse it, but it rounds the last part:

$("input.class").data("sku") 
// -> 13309600171106320000

If I try to parse the string as an int I have the same result:

parseInt("13309600171026321254")
// -> 13309600171106320000

I assume it's a bug on parseInt function but this kind of errors could be detected and then return the original string instead of trying to parse it.

Change History (3)

comment:1 Changed 5 years ago by shholmes@…

I didn't notice I must put the code in jsFiddle sorry (and I have a typo on the example :( ).

Code testing this bug is in http://jsfiddle.net/cLyTE/1/

comment:2 Changed 5 years ago by dmethvin

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 5 years ago by dmethvin

Duplicate of #7579.

Note: See TracTickets for help on using tickets.