Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11372 closed bug (duplicate)

html() does not work for <link>

Reported by: yiminghe Owned by:
Priority: low Milestone: None
Component: manipulation Version: git
Keywords: Cc:
Blocked by: Blocking:

Description

  1. open http://jsfiddle.net/QF7e8/4/ in ie6789,chrome,firefox

expected:

all browser are same , "1" does not have a circle before it.

actual:

in ie678 , "1" has a circle before it

Change History (6)

comment:2 Changed 10 years ago by sindresorhus

Component: unfiledmanipulation
Priority: undecidedlow

.append() works, .html() doesn't.

From the HTML spec:

This element defines a link. Unlike A, it may only appear in the HEAD section of a document

Even though '<link>' should only be in head, browsers are apparently very forgiving. Since it should only be in head, you can't really use .html() there, so not really sure if this should be fixed.

comment:3 Changed 10 years ago by cmcnulty

Also reported in #11528 and fixed with pull request 718

comment:4 in reply to:  2 Changed 10 years ago by cmcnulty

Replying to sindresorhus:

Even though '<link>' should only be in head, browsers are apparently very forgiving. Since it should only be in head, you can't really use .html() there, so not really sure if this should be fixed.

And for the record, I agree with this comment, except that we already fix it in cases of style and script, so we have a precedent, and the code is as easy as adding link to the noInnerhtml text

comment:5 Changed 10 years ago by sindresorhus

Resolution: duplicate
Status: newclosed

comment:6 Changed 10 years ago by sindresorhus

Duplicate of #11528.

Note: See TracTickets for help on using tickets.