Bug Tracker

Opened 5 years ago

Closed 5 years ago

#11321 closed bug (invalid)

.clone().addClass() don't work together

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

When an object is copied and a class attempts to be added to the copied object, it will not work. Example.

<div class="cloneclass"> clone me </div>

<div class="appendclass"></div>

$('.cloneclass')
    .clone()
    .addClass('addtest')
    .css({...})
    .appendTo('.apendclass');

This is the output

<div class="cloneclass"> clone me </div>

<div class="appendclass">
    <div class="cloneclass"> clone me </div>
</div>

Change History (2)

comment:1 Changed 5 years ago by sindresorhus

Owner: set to anonymous
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.