Bug Tracker

Opened 13 years ago

Closed 13 years ago

#1132 closed enhancement (fixed)

Remove connect:close header workaround

Reported by: joern Owned by: joern
Priority: minor Milestone: 1.1.3
Component: ajax Version: 1.1.2
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery contains a workaround for a bug in pre 1.5 Firefox that can be safely removed (anything older then FF 1.5 isn't supported anyway).

The relevant lines:

// Make sure the browser sends the right content length
if ( xml.overrideMimeType )
	xml.setRequestHeader("Connection", "close");

Link to some resources about the issue: The root cause of the hack (Dan just touched on it):

https://bugzilla.mozilla.org/show_bug.cgi?id=246651

Message reporting that the above bug was fixed in the 11 Sep 2004 build :

http://forums.mozillazine.org/viewtopic.php?p=788974

Two bugs from prototype (the second is marked duplicate):

http://dev.rubyonrails.org/ticket/5606 http://dev.rubyonrails.org/ticket/5809

Resulting from a recent discussion: http://groups.google.com/group/jquery-en/browse_thread/thread/8ff37a5c8660f4ec

Change History (1)

comment:1 Changed 13 years ago by joern

Resolution: fixed
Status: newclosed

Fixed in [1733].

Note: See TracTickets for help on using tickets.