Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11314 closed bug (duplicate)

In IE, jQuery's presence causes other scripts using 'defer' to not run at all

Reported by: dave@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

In IE7 and IE8, when jQuery 1.4.3 - 1.7.1 is present in a page, an unrelated script that has a defer attribute won't execute at all, if that script takes a while to load.

Example: http://brondsema.net/tmp/jquery_script_defer.html

  • jQuery 1.4.2 does not exhibit this behavior. Something introduced in 1.4.3 triggers it.
  • IE9 does not exhibit this behavior. Something was fixed in IE9
  • if the 'defer' script loads quickly (e.g. before domready or something like that), then it will execute.
  • Dynamically inserting a script DOM element that has defer=true does not exhibit this behavior. It is only when using the script tag and defer attribute in the HTML.

Change History (2)

comment:1 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by dmethvin

Duplicate of #11310.

Note: See TracTickets for help on using tickets.