Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#11303 closed bug (invalid)

FadeIn doesn't keep block format

Reported by: ryannaddy Owned by:
Priority: low Milestone: None
Component: effects Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

While using fadeIn() on an <a> tag with a css "block" display type, it removes the block format when it fades in. It seems to do the same on other inline elements as well. It works fine on the <div> tag though.

Example: http://jsfiddle.net/NZ3eF/1/

Change History (2)

comment:1 Changed 7 years ago by sindresorhus

Component: unfiledeffects
Priority: undecidedlow
Resolution: invalid
Status: newclosed

Simplified testcase: http://jsfiddle.net/mofle/NZ3eF/3/

The problem is that you have a rule "display: none" after "display: block" which overwrites it. Since the display value is none, jQuery will instead use the default display value of the a-tag, which is "inline".

You can work around this by doing something like this instead:

$('.nav-link').fadeIn().css('display', 'block');

comment:2 Changed 6 years ago by Sagan Internet Marketing

Thanks for the idea to use

.css('display', 'block');
Note: See TracTickets for help on using tickets.