Bug Tracker

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#113 closed bug (invalid)

hover() mouseout bug

Reported by: anonymous Owned by:
Priority: major Milestone: 1.0
Component: event Version: 1.0
Keywords: Cc:
Blocked by: Blocking:

Description

This code is not calling the mouseout function in firefox or IE according to my tests:

$("li").hover( function(){$(this).addClass("active");}, function(){$(this).removeClass("active");} );

Change History (5)

comment:1 Changed 14 years ago by john

Milestone: 1.0
Version: 1.0

comment:2 Changed 14 years ago by john

Resolution: fixed
Status: newclosed

This has been resolved in SVN.

comment:3 Changed 14 years ago by mmihajlovic@…

Resolution: fixed
Status: closedreopened
Summary: hover() mouseout bug in rev 165hover() mouseout bug

I'm still getting an error on IE. Althoug I haven't tested it, I think the problem is with removeClass and not the MouseOut event. This is still happening in ver 1.

comment:4 Changed 14 years ago by mmihajlovic@…

Damn, I goofed. The problem is actually with toggle, not removeClass. Should I create a new bug entry?

comment:5 Changed 14 years ago by joern

Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.