Bug Tracker

Opened 8 years ago

Closed 8 years ago

#11285 closed bug (invalid)

jQuery Ajax call causing IE8 to crash when data returned from WCF service

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have created a WCF web service. I call this usinq jQuery 1.7.1

try { 
    $.ajax({ 
        type: "GET", 
        url: '/_vti_bin/PROJ/WCF.svc/GetDetails', 
        contentType: "application/json; charset=utf-8", 
        data: myid, 
        success: function (msg) { 
            wcfServiceGetSucceeded(msg); 
        }, 
        error: wcfServiceGetFailed 
    }); 
} catch (e) { 
    alert('error invoking service.get()' + e); 
}

This is working on all browsers when the results size is small. When the result size is bigger IE8 crashes. Chrome and IE9 work fine. The body of the json returned is 51,856(not sure what the units are in fiddler). IE crashes completely. It hangs and nothing is displayed. The IE process needs to be killed.

Change History (7)

comment:1 Changed 8 years ago by sindresorhus

Owner: set to anonymous
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:3 Changed 8 years ago by sindresorhus

Status: newpending

This bug tracker is not a support forum, and is only for solving reproducible, verifiable bugs with jQuery Core itself.

Please provide a jsfiddle testcase.

comment:4 Changed 8 years ago by anonymous

Status: pendingnew

Creating a test case now and will add.

comment:5 Changed 8 years ago by anonymous

Do you have any suguestions of how to mock ~450,000 bytes being returned from jsfiddle? Posting the dat in is giving me a 413

Request Entity Too Large

comment:6 Changed 8 years ago by dmethvin

Status: newpending

You'll need to debug this further so it can be shown to be a jQuery core bug. In any case that is a very large return, so it may just be that IE8 has some performance issue with a response that large.

comment:7 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.