Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11274 closed bug (duplicate)

Indeterminate checkboxes not matched with :checked selector in WebKit browsers

Reported by: lowbatteries Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

If a checkbox is checked, but then has the indeterminate property set, it will not be matched with the :checked selector (even though it is still checked, and would be posted with a form submission).

Reduced case here: http://jsfiddle.net/7TcKF/3/

This seems to boil down to .webkitMatchesSelector(':checked') which has the same incorrect behavior.

The issue does not appear in jQuery 1.2.6 or 1.3.2, but seems to have been introduced in 1.4.4 and onwards.

I confirmed the erronous behavior in Chrome 16, Chrome 18 (Canary), Safari 5.1.2, and WebKit nightly. This bug does not show up in Opera, IE6+, or Firefox.

Change History (2)

comment:1 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:2 Changed 7 years ago by dmethvin

Duplicate of #11273.

Note: See TracTickets for help on using tickets.