Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11270 closed bug (duplicate)

After updating to jQuery 1.7.1 Animate stops working

Reported by: [email protected] Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

After updating to jQuery 1.7.1 from 1.4.2 it seems that the backgroundPosition property of the .stop().animate function no longer works.

Here is the code:

[code] <script type="text/javascript">

var J = jQuery.noConflict();

J(window).load(function() {

var pos = J("#leftBanner").position();

J("#leftBanner").css("background-position", "-50px"); J("#leftBanner").css("opacity", "0");

J("#leftBanner").stop().animate({

backgroundPosition: "+=50px 0px", opacity: 1.0

}, 2000);

});

</script>';

code

Whilst the opacity still changes the image starts at the correct position left but does not animate to the right like it is supposed to.

Downgrading back to the old version of jQuery fixes the problem.

Thanks Robin

Change History (2)

comment:1 Changed 10 years ago by timmywil

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by timmywil

Duplicate of #7755.

Note: See TracTickets for help on using tickets.