Bug Tracker

Opened 8 years ago

Closed 8 years ago

#11256 closed bug (invalid)

serialize() doesn't produce the exact same string as when you actually send the form: utf8 characters encoded differently

Reported by: matteosistisette Owned by: matteosistisette
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

Steps to reproduce:

  • create a HTML form
  • paste some chinese characters into a text field
  • send the form

=> the chinise characters are converted into html entities, e.g. 投 and sent

Now copy the same input into the text field and call serialize() on the same form => the chinese characters are just url-encoded without previously converting them into html entities e.g. %E6%8A%95

The serialize() method should produce EXACTLY the same string that the browser places into the request when sending the same form.

Though, I am not sure whether this is a bug in jQuery or in the Javascript engine itself.

Change History (3)

comment:1 Changed 8 years ago by matteosistisette

Sorry for the formatting. The "Steps to reproduce" part doesn't end where the list ends. The "Now copy..." part is the last step.

comment:2 Changed 8 years ago by Rick Waldron

Owner: set to matteosistisette
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the "jQuery (edge)" version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to begin.

comment:3 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.