Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#11202 closed bug (duplicate)

No support for XDomain request in IE

Reported by: digitalpacman@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

Please put in cross browser support for cross domain ajax calls when utilizing HTML5. IE8+ needs to use XDomain not CORS. Thanks!

<reasoning> I do not care that there is a ticket marked "plugin" for the solution to this.

How is a developer writing an API supposed to tell people to use this extension in jquery and write specific code for IE. It's going to make us look stupid.

JQuery's whole purpose is to support the incompatabilities and differences between browsers. With html5 becoming so much larger, SaaS applications being wanted more and more, and JSON apis being exposed more and more every day, YOU NEED TO SUPPORT THIS NATIVELY.

Now I can't use CORs at my work and have to write JSONP services just to forward to my normal services, for every service, because this isn't supported natively I am told "its not OK to tell an integrator that they have to download a non-standard plugin to use our API".

Just. Work. Cross. Browser. </reasoning>

Thanks!

Change History (5)

comment:1 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

You know about all the restrictions and shortcomings in XDR, right? We can't hide them, so it would only work on a subset of XHR-CORS situations. When you include a plugin to do that you are explicitly aware of those.

comment:2 Changed 9 years ago by dmethvin

Duplicate of #8283.

comment:3 in reply to:  1 ; Changed 9 years ago by digitalpacman@…

Replying to dmethvin:

You know about all the restrictions and shortcomings in XDR, right? We can't hide them, so it would only work on a subset of XHR-CORS situations. When you include a plugin to do that you are explicitly aware of those.

It's funny that you would use that as an argument considering when you turn JSONP on that you just start ignoring settings because of the "loss of functionality". Obviously its ok for the core team to do it for JSONP so why not for CORS?

comment:4 in reply to:  3 Changed 9 years ago by Rick Waldron

Replying to digitalpacman@…:

It's funny that you would use that as an argument considering when you turn JSONP on that you just start ignoring settings because of the "loss of functionality". Obviously its ok for the core team to do it for JSONP so why not for CORS?

Hey that's rude. Did you know that JSONP is just a script tag and temporary function? It doesn't have the benefit of being an actual XHR object. Thanks for your understanding

https://github.com/jaubourg/ajaxHooks/blob/master/src/ajax/xdr.js

comment:5 Changed 9 years ago by digitalpacman@…

I understand how its implemented, infact, I've made modifications to improve it to support things such as status codes.

I know the limitations, I know why they are there. The fact stands that when you use it you can still set settings such as a method, etc, and they simply get ignored. No errors, nothing. They just go. So I do not see why, that functionality can be applied to JSONP and not a CORS request. Why not just implement a CORS type instead of JSON/JSONP and put cross functionality in there?

There is absolutely no reason to say that we shouldn't support it except for a boycott against IE cause of their stupid decisions that go against what the rest of the worlds doing.

Yes, sorry for being rude, but its 2012 and I still feel like I'm in 2005 because of IE and people who have this hatred towards them so they ignore supporting their fumbles.

Seems that jquery core team also does it in regards to apple, some what, because the document height is broken on iphone. And that "bug" is being ignored as well.

Note: See TracTickets for help on using tickets.