Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11195 closed enhancement (wontfix)

Toggle should also toggle visibility hidden/visible

Reported by: design@… Owned by:
Priority: low Milestone: None
Component: css Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

For accessibility purposes any toggle function should also utilize visibility: hidden and visibility: visible for maximum compatibility with a wide range of screen readers for the disabled.

http://www.456bereastreet.com/archive/200711/screen_readers_sometimes_ignore_displaynone/

Change History (3)

comment:1 Changed 8 years ago by timmywil

Component: unfiledcss
Priority: undecidedlow
Resolution: wontfix
Status: newclosed

This would cause a lot of unexpected behavior for our users. I suggest using the .css() method to set visibility instead.

comment:2 Changed 8 years ago by dmethvin

Agree with timmywil here, it's too disruptive for us to change jQuery's behavior of show/hide. Instead you could implement your own small plugins that change all related css and use those instead. Or better still, use classes along with addClass/removeClass since that will allow you to attach CSS transitions as well.

comment:3 Changed 8 years ago by design@…

What about an alternate toggle function such that you have with Width, outerWidth etc?

This is a common bit of accessibility which I feel shouldn't be something that has to be custom coded in every case.

Note: See TracTickets for help on using tickets.