Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11180 closed bug (invalid)

document.defaultview.getcomputedstyle null

Reported by: Mike Helmick <mikehelmick@…> Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

Related to http://bugs.jquery.com/ticket/8763, I believe.

SWFUpload is trying to load in a page that is loaded in through an iframe that is hidden in a div, and then shown.

The div is hidden, src (that includes swfupload) is added to iframe, iframe is appended to div, then div is shown.

SWFUpload throws: line 274 - swfupload.js

document.defaultView.getComputedStyle(targetElement, null) is null
[Break On This Error] wrapperType = (targetElement.curre...play")) !== "block" ? "span" : "div"; 

SWFUpload v2.2

I know there are newer versions out of SWFUpload, but yeah; this needs looked at.

Change History (1)

comment:1 Changed 8 years ago by dmethvin

Resolution: invalid
Status: newclosed

It would be best to start with a test case that reproduces the problem, using the latest plugin, and report it to the maintainers of swfupload.js since the error occurs in that code.

Note: See TracTickets for help on using tickets.