Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11157 closed bug (duplicate)

Attribute filter can't deal with colons

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

Given some rss 2.0 it's quite hard to get the content:encoded property. (Tested browser: current Chromium nightly build)

broken: .find('[nodeName="content:encoded"]')

also broken: .find('content
:encoded')

workarounds .find('encoded') mostly not applicable .filter(function(){ return this.nodeName === 'content:encoded')

I would have expected the last workaround to be identical to what the attribute filter actually does

Change History (2)

comment:1 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: newclosed

nodeName is not an attribute (it's a property) so the attribute filter doesn't apply to it. Use .filter() with a function or some other method to look at the property.

comment:2 Changed 8 years ago by dmethvin

Duplicate of #10377.

Note: See TracTickets for help on using tickets.