Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11156 closed bug (duplicate)

.WIDTH() ON HIDDEN CELL MESSES UP TABLE LAYOUT IN GOOGLE CHROME

Reported by: romario333 Owned by:
Priority: low Milestone: None
Component: dimensions Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

In Google Chrome, when you call .width() on a hidden cell and then make the cell visible, it is shifted to the right from its original position.

Here is a test-case: http://jsfiddle.net/romario333/9bqhA/

It looks like a webkit issue, I've already reported it: https://bugs.webkit.org/show_bug.cgi?id=75798

In Firefox and IE the table renders correctly.

I've already created ticket for this bug earlier, but it was closed as invalid. I believe that this bug is valid, as I run into it quite often in my code and jQuery's task should be to hide browser differences from me. Here is the original ticket: http://bugs.jquery.com/ticket/11132

Change History (2)

comment:1 Changed 8 years ago by addyosmani

Component: unfileddimensions
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

As this is a duplicate of the older ticket I'll close this one and re-open the other for a second review.

comment:2 Changed 8 years ago by addyosmani

Duplicate of #11132.

Note: See TracTickets for help on using tickets.